Chapter 3. Getting Started With gx25adm

The gx25adm utility is a graphical interface for configuring the SX.25 application on Silicon Graphics workstations and servers. Using gx25adm menus and dialogs, you can configure connections to X.25 WANs, X.25 LANs, or connections to IP networks. You can also configure PAD and other user applications that rely on the underlying X.25 network connection. Because configuration parameters are preset to conform to the requirements of most X.25 network service providers, the configuration process is quick and efficient.

This chapter contains these sections to help you get started using gx25adm:

Starting the gx25adm Utility

The gx25adm utility allows a privileged user or root to configure the protocol stack for an X.25 port on a host; gx25adm also allows you to configure features on the host that support network services. The utility is accessible from the Indigo Magic Desktop. You can start gx25adm by any of the these methods:

From the Find Toolchest

Use this procedure to start gx25adm from the Find toolchest:

  1. Choose “An Icon” from the Find toolchest.

  2. Type gx25adm in the “Find an Icon” dialog.

  3. Drag the icon onto your desktop.

  4. Double-click on the gx25adm icon to launch the utility.

From the Icon Catalog

Use this procedure to start gx25adm from the Icon Catalog:

  1. Choose “Desktop Tools” from the Find toolchest.

  2. Double-click the gx25adm icon to launch the utility.

From a Shell

If you are configuring a remote workstation or server from a local system that runs from an ASCII console, start gx25adm from a shell. In this case, the local system must be running xeoe client software (see the SX.25 Release Notes for information on software prerequisites).

Use this procedure to start gx25adm from a shell:

  1. Type su to become the root user.

  2. Type gx25adm command from an IRIX shell:

    # gx25adm
    

Using the Primary Window

The gx25adm primary window is displayed when you start the gx25adm utility (see Figure 3-1). Use the primary window to access the list of ports that are present on the SX.25 host, and to access the menus and other windows that allow you to configure the host and its ports for operation on an X.25 network.

When you first start gx25adm, the ``Ports:'' list is empty. To display entries in the ports list, open an SX.25 configuration file (see “Using the File Menu” for information on opening files). Then, use the ports list to select a port to be configured, reconfigured, or removed from the configured ports list.

Figure 3-1. Primary Window for gx25adm


Click these topics to view more information about the primary window:

Primary Window Tabs

When you select the Configured tab (shown in Figure 3-1), the primary window shows a list of ports that are already configured for network operation. When you select the Unconfigured tab (shown in Figure 4-2), the primary window shows a list of ports that are available but not yet configured. (Remember that the configuration file must be open to display a ports list.) Notice from Figure 3-1 and Figure 4-2 that the buttons on the primary window change, depending on the tab that is selected.

Primary Window Buttons

When the Unconfigured tab is active, select a port on the ports list and click the Configure button to display an empty port configuration record. Complete this record to configure the port (see “WAN Port Configuration Procedure” and “LAN Port Configuration Procedure” in Chapter 4 for instructions).

When the Configured tab is active, select a port on the ports list and click the Display button to display the current port configuration record. Make the necessary changes to this record to reconfigure the port. If you want to remove a port from the ports list, click the Delete button. If you save the configuration file after removing the port from the list, you remove the port from service and the port is returned to the Unconfigured ports list (see “Using the File Menu” for instructions on saving the configuration file).

Using the File Menu

Use the File menu, shown in Figure 3-2, to open and save configuration files, the files that define how individual X.25 ports on the system operate. For any given port on the system, this file must contain a subnetwork and network address and the name of the parameter files that define the protocol stack for the port. Also use the File menu to create customized versions of the protocol parameter files (if you determine that the original SX.25 parameter files are unsuitable for your needs) and to save updates to the maps and other records that support SX.25 options.


Note: Information that you add to a configuration file or protocol parameter file during an gx25adm session is not permanently recorded until you explicitly save the file using the ``Save'' or ``Save As'' option on the File menu.

Figure 3-2. File Menu


Click these topics to view information about File menu options:

The New Option

Use the ``New'' option at the beginning of a port configuration session to create a configuration file that does not currently exist. The new file will contain the information that you enter in gx25adm windows during the session. This information will be recorded in the new file when you save it with the ``Save'' or ``Save As'' option.

The Open Option

Use the ``Open'' option at the beginning of a port configuration session to open an existing configuration file to review its contents or change them. When you select this option, gx25adm prompts you to enter the name of the file that you plan to modify. Enter the full pathname of the file. It is important to remember that no changes are made to this file until you save it using the ``Save'' or ``Save As'' option.

The Save Option

Use the ``Save'' option to store information in a configuration file that you opened earlier in the session. If you are saving a new configuration file, gx25adm prompts you to enter a filename. Enter the full pathname of the file. You can save the new file in any directory; however, by convention, IRIX configuration files are stored in the /etc/config directory. If you are saving changes to an existing file, gx25adm saves a new copy of the file that you specified when you opened the file.

The Save As Option

Use the ``Save As'' option to store a configuration file under a new filename. When you select this option, gx25adm prompts you to enter the new filename. Enter the full pathname of the file. You can save the file in any directory; however, by convention, IRIX configuration files are stored in the /etc/config directory.

The Exit Option

Use the ``Exit'' option to end a gx25adm session. If you made any configuration changes that you want to save, be sure to use the ``Save'' or `'Save As'' options on the File menu before selecting the ``Exit'' option. If you have any unsaved changes remaining from the session when you select the ``Exit'' option, gx25adm warns you that your changes will be lost unless you take action with ``Save'' or `'Save As.''

Using the Edit Menu

Use the Edit menu, shown in Figure 3-3, to set the IRIX kernel parameters for an SX.25 host and to configure the optional features that SX.25 offers. SX.25 optional features rely on maps and other information about network hosts and services that you supply during gx25adm sessions. This information is stored in the configuration file (snetd.options, by default) and other supporting files.

Whenever you create or modify a configuration file, you must save your changes using File menu options. Whenever you create or modify supporting files, you use the Close button to save your changes (shown in Figure 5-2). To put the new file into effect, you must also stop and restart the network using Action menu options. Whenever you use the Edit menu to set kernel parameters, you must reboot the SX.25 host.

Figure 3-3. Edit Menu


Click these topics to view information about Edit menu options:

The PAD Map/Xhosts Option

Use the ``PAD Map/Xhosts'' option to create a list of the names of remote PADD hosts and the connection information that the hosts require. This map reduces the amount of information that users must supply when they begin a PAD session. After the list is created, use this option to modify X.25 host information or remove hosts from the list. See “The PAD Map Option” in Chapter 5 for instructions on creating the PADD map.

The IXE Map Option

Use the ``IXE Map'' option to create the list of Internet (IP) hosts with which this system will communicate. You are required to supply the name and address of each IP host; you can also specify a host alias if you choose to use one. After the list is created, use this option to modify Internet host information or remove hosts from the list. See “The IXE Map Option” in Chapter 5 for instructions on creating the IXE map.

The PADD Option

Use the ``PADD'' option to compose a list of listen strings that identify the calls for which the SX.25 host will provide PAD services. Incoming calls for service are handled by the PAD daemon, PADD. See “The PADD Listen Strings Option” in Chapter 5 for instructions on creating and changing this list.

The Subnetworks Option

Use the ``Subnetworks Option'' to create a list of the subnetwork names on this host. The subnetwork list allows users to designate subnetworks by a name instead of by an address. See “The Subnetwork Names Option” in Chapter 5 for instructions on configuring subnetwork names.

The Kernel Parameters Option

Use the ``Kernel Parameters'' option to set system-wide limits on the number of virtual circuits and UUCP connections that an SX.25 host will support. Because these parameters affect the IRIX kernel, you must reboot the SX.25 host whenever you use this option. See “Procedure to Configure Global Kernel Parameters” in Chapter 4 for instructions on configuring global kernel parameters.

Using the Action Menu

Use the Action menu, shown in Figure 3-4, to start and stop networking and to create a new IRIX kernel.


Caution: When you use this menu to stop networking, all network activity is suspended until you restart the host; when you use this menu to rebuild the IRIX kernel, the X.25 host must be rebooted.

Figure 3-4. Action Menu


Click these topics to view information about Action menu options:

The Network Option

Use the ``Network'' option to start and stop X.25 operations on the system. When you select ``Start'' from this option, gx25adm prompts you to specify the configuration file to be used for operation. Enter the full pathname of the configuration file or use the Filter button on the file specification prompt to enter wildcards in your specification. If the configuration file that you specify contains any changes, the changes become effective at network startup. An information message is posted when the network starts.

When you select ``Stop'' from this option, an information message is posted when the network stops. Stopping the network suspends connections to all networks in which the host is a member.

The Create Kernel Option

Use the ``Create Kernel'' option to build a new IRIX kernel after you set new IRIX kernel parameters with the ``Kernel Parameters'' option on the Edit menu (see “The Kernel Parameters Option” in Chapter 3 for details) or the Setup menu on the WAN port configuration window (see “The Setup Menu” in Chapter 4 for details). Selecting the ``Create Kernel'' option configures and stores the new IRIX kernel; however, the new kernel is not installed until the next system reboot. See “Procedure to Rebuild the IRIX Kernel” in Chapter 4 for instructions on configuring and rebuilding an IRIX kernel.

Using gx25adm Help

Use the Help menu on the primary window (see Figure 3-1) to display a list of the help topics that are available from this window. Select the ``Overview'' option to display general information about the primary window and port configuration windows and the features that these windows offer.

In addition to the Help menu, you can also get help on individual window features by using the F1 key. For example, to request help on the File menu, move the cursor to the label on the menu bar and press F1.

Configuration Procedure at a Glance

Figure 3-5 illustrates a typical gx25adm session in which an SX.25 host is configured for basic X.25 network connection services. In this session, the host's global parameters are configured first, then individual ports on the host are configured. When all ports are configured, configuration information is saved in the configuration file and the IRIX kernel is rebuilt.

Figure 3-5. The Port Configuration Process


The order of the configuration process can vary from the order that is illustrated in Figure 3-5. However, because all changes to global parameters and some changes to individual port parameters affect the IRIX kernel, you must rebuild the IRIX kernel (the final step in Figure 3-5) after configuring kernel parameters.

Notice from Figure 3-5 that individual port configurations might be interrupted by an additional step: creating custom parameter files. If SX.25 factory-shipped parameter files are not suitable for connection to a particular network, you must create custom parameter files as part of the configuration process (see “Protocol Parameter Files” in Chapter 1 for information on factory-shipped files). Any custom file that you create can be used to configure other ports that require the same parameters. (Detailed configuration instructions are given in Chapter 4.)

Figure 3-5 does not include procedures for configuring the optional X.25 features that SX.25 offers. In general, however, optional features are added to a port after it is configured for the basic connection service. Options that affect the SX.25 host (such as PADD services) can be added at any time. (See Chapter 5 for a list and description of SX.25 optional features and instructions on configuring them.)