About This Guide

“About This Guide” includes brief descriptions of the contents of this guide and an explanation of typographical conventions used, and refers you to additional sources of information you might find helpful.

This guide explains how to perform general operation tasks of the provision distributed system monitoring application, used with Silicon Graphics® workstations and servers.

What This Guide Contains

This guide contains the following chapters:

How to Use This Guide

This guide is written for administrators who are responsible for configuring and maintaining the provision implementation at their site.

Target Audience of This Guide

This guide is intended for administrators who are responsible for one or more systems running the provision distributed system monitor.

Additional Resources

For easy reference, here is a list of the guides and resources provided with your system and the specific focus and scope of each:

IRIX Admin Manual Set

This guide is an additional resource to the IRIX Admin manual set.

The IRIX Admin suite is intended for administrators: those who are responsible for servers, multiple systems, and file structures outside the user's home directory and immediate working directories. If you find yourself in the position of maintaining systems for others or if you require more information about IRIX than is in the end-user manuals, these guides are for you. The IRIX Admin guides are available through the IRIS InSight online viewing system. The set comprises these volumes:

  • IRIX Admin: Software Installation and Licensing —Explains how to install and license software that runs under IRIX, the Silicon Graphics implementation of the UNIX® operating system. Contains instructions for performing miniroot and live installations using Inst, the command line interface to the IRIX installation utility. Identifies the licensing products that control access to restricted applications running under IRIX and refers readers to licensing product documentation.

  • IRIX Admin: System Configuration and Operation —Lists good general system administration practices and describes system administration tasks, including configuring the operating system; managing user accounts, user processes, and disk resources; interacting with the system while in the PROM monitor; and tuning system performance.

  • IRIX Admin: Disks and Filesystems —Describes how to add, maintain, and use disks and filesystems. Discusses how they work, their organization, and how to optimize their performance.

  • IRIX Admin: Networking and Mail —Describes how to plan, set up, use, and maintain the networking and mail systems, including discussions of sendmail, UUCP, SLIP, and PPP.

  • IRIX Admin: Backup, Security, and Accounting —Describes how to back up and restore files, how to protect your system's and network's security, and how to track system usage on a per-user basis.

  • IRIX Admin: Peripheral Devices —Describes how to set up and maintain the software for peripheral devices such as terminals, modems, printers, and CD-ROM and tape drives. Also includes specifications for the associated cables for these devices.

  • IRIX Admin: Selected Reference Pages (not available in InSight)—Provides concise reference page (manual page) information on the use of commands that may be needed while the system is down. Generally, each reference page covers one command, although some reference pages cover several closely related commands. Reference pages are available online through the man(1) command.

Reference Pages

The IRIX reference pages (often called “man” or “manual” pages) provide concise reference information on the use of IRIX commands, subroutines, and other elements that make up the IRIX operating system. This collection of entries is one of the most important references for an administrator. Generally, each reference page covers one command, although some reference pages cover several closely related commands.

The IRIX reference pages are available online through the man command. To view a reference page, use the man command at the shell prompt. For example, to see the reference page for diff, enter:

man diff 

It is a good practice to print those reference pages you consistently use for reference and those you are likely to need before major administrative operations and keep them in a notebook of some kind.

Each command, system file, or other system object is described on a separate page. The reference pages are divided into seven sections, as shown in Table i. When referring to reference pages, this document follows a standard UNIX convention: the name of the command is followed by its section number in parentheses. For example, cc(1) refers to the cc reference page in Section 1.

Table i shows the reference page sections and the types of reference pages that they contain.

Table 1. Outline of Reference Page Organization

Type of Reference Page

Section Number

General Commands

(1)

System Calls and Error Numbers

(2)

Library Subroutines

(3)

File Formats

(4)

Miscellaneous

(5)

Demos and Games

(6)

Special Files

(7)


Release Notes

Provide specific information about the current release. Exceptions to the administration guides are found in this document. Release Notes are available online through the relnotes command. Each optional product or application has its own set of release notes. The grelnotes command provides a graphical interface to the release notes of all products installed on your system.

The IRIX Help System

Your IRIX system comes with a help system. This system provides help cards for commonly-asked questions about basic system setup and usage. The command to initiate a help session is desktophelp.

The Silicon Graphics World Wide Web Site

The Silicon Graphics World Wide Web (WWW) presence has been established to provide current information of interest to Silicon Graphics customers. The following URLs are accessible to most commercially available Web browsers on the Internet:

http://www.sgi.com  


The Silicon Graphics general Web site, Silicon Surf

http://www.mips.com  


The Silicon Graphics mips division site

http://www.studio.sgi.com  


The Silicon Studio site

http://www.alias.com  


The Alias site

http://www.sgi.com/Technology/TechPubs  


The Silicon Graphics Technical Publications Library

From these sites you can find all the Silicon Graphics Web-published information, including the Technical Publications Library.

Conventions Used in This Guide

These type conventions and symbols are used in this guide:

Bold 

User account names.

Italics 

Filenames, glossary entries (online, these show up as underlined), IRIX commands, manual/book titles, new terms, onscreen button names, program variables, variable command-line arguments, and variables to be supplied by the user in examples, code, and syntax statements

Fixed-width type 


Onscreen text and MIB specifications

Bold fixed-width type 


User input, including keyboard keys (printing and nonprinting); literals supplied by the user in examples, code, and syntax statements (see also <>)

“” 

(Double quotation marks) Onscreen menu items and references in text to document section titles

() 

(Parentheses) Following IRIX commands—surround reference page (man page) section number

<> 

(Angle brackets) Surrounding nonprinting keyboard keys, for example, <Esc>, <Ctrl-D>

This guide uses the standard UNIX convention for citing reference pages in the IRIX documentation. The page name is followed by the section number in parentheses. For example, rcp(1C) refers to the rcp online reference page.

User Interface Terminology

Figure i and Figure ii show examples of windows, with the window terms used in this guide noted.

Figure 1. Window Terms


The mouse buttons have these functions:

left 

Perform most basic tasks: click buttons, select an entry field to type into, select menu choices, select items in a display, select text to modify, and so on.

middle 

Reposition windows and icons.

right 

Access popup menus. Popup menus appear when you press the right mouse button in certain locations on the screen.

Figure 2. More Window Terms


This guide uses the following terms to describe the use of the mouse:

press 

Hold down a mouse button.

drag 

Move the mouse while a mouse button is pressed.

click 

Press a mouse button and immediately release it without moving the mouse.

double-click 

Press and release a button twice in quick succession without moving the mouse.

select 

The term “select” is used in the following ways:

  • Click the left mouse button on an item to highlight it.

  • Press the left mouse button in an entry field, drag the cursor across some or all of the text, and release the mouse button. The text becomes highlighted.

  • Press the left mouse button on a menu title in a menu bar, move the cursor to a menu choice, and release the mouse button while a menu choice is highlighted.

deselect 

Click a highlighted item to turn off the highlighting.

Common User Interface Operations

This guide assumes that you are familiar with using the mouse, working with windows, and using pulldown and rollover menus. These operations are described in the IRIS Essentials guide.

The sections below explain how to use additional components of the user interface that are common to several of the tools.

Using Scroll Bars

You can use scroll bars (see Figure iii) to change the area and scale of a viewing area and to display different lines or portions of lines in a display area. The size of the slider is proportional to the amount of the total that you are viewing. You operate scroll bars by pressing the left or middle mouse button when the cursor is in the scroll bar. There are several ways to operate the scroll bar:

  • Press the left mouse button on the slider, drag the cursor to a new slider position, and release the button.

  • Move the slider incrementally by clicking the triangles at each end of the scroll bar.

  • Move the slider up or down by positioning the cursor in the trough above or below the slider and clicking the left mouse button.

  • Move the slider to a specific position by positioning the cursor at that position and clicking the middle mouse button.

    Figure 3. A Horizontal Scroll Bar


Entering and Removing Text in a Field

Editing text in the entry fields (see Figure iv) is the same as editing text in the entry fields of other applications:

  • Position the text insertion point by moving the mouse to the entry field and clicking the left mouse button.

  • Select (highlight) text by pressing the left mouse button at one end of the text that you want to select and dragging to the other end.

  • Select a word including a space or punctuation-delimited characters by moving the cursor to the word and double-clicking the left mouse button.

  • Select the entire contents of an entry field by moving the cursor over the entry field and triple-clicking the left mouse button.

  • Delete selected (highlighted) text by pressing the <Backspace> key.

  • Delete the character to the left of the insertion point by pressing the <Backspace> key.

    Figure 4. An Entry Field


Using Option Buttons

Option buttons (on the left in Figure v) let you select a numeric value from among a predefined set of choices. To use an option button, first press the option button with the left mouse button. A menu pops up (on the right in Figure v). Move the cursor to your selection and release the mouse button.

Figure 5. An Option Button and an Option Button Menu


Using a File Prompter

File prompter windows (like the one in Figure vi) are used to specify filenames. You can choose a filename by double-clicking a name in the display area. You can also type the name into the filename entry field and press <Enter> or click the Accept button to complete your filename selection. You can change directories to the parent of the current directory by clicking the Up button, or return to the directory where you started the tool by clicking the Original button.

Figure 6. A File Prompter Window


Using Online Help

The provision tool provides many online help files to help you as you learn to use the tools. You access these files from the Help menu in the menu bar of many provision windows (shown in Figure vii on top) and from the Help button that appears in some provision windows (on the bottom in Figure vii).

Figure 7. A Help Menu and a Help Button


When you choose “Help...” from a menu or click a Help button, a Showcase window appears and displays the first help card.

Some help files contain several cards. Page through these cards using the <Page Up> and <Page Down> keys in the cluster of six keys just to the right of the <Backspace> key or click the left mouse button on the arrows at the bottom of the pages. Make sure the cursor is in the Help window when you press these keys.

When you're finished reading a help file, you can close the Help window just as you close any other window, for instance, by double-clicking the Window menu button in the upper left corner of the window or by selecting Quit from the Window menu.